読者です 読者をやめる 読者になる 読者になる

ノラプログラマーの技術メモ

ネットで調べても出てこなかった情報を載せていきたい技術系ブログ。

EC-CUBE3でAPC拡張モジュールが有効になっていません。のエラーが出た時の対処方法

EC-CUBE3.0系をサーバー上に展開して、htmlフォルダ内のinstall.phpにアクセスしてみると次の警告が表示された。

[推奨PHPライブラリ]APC 拡張モジュールが有効になっていません。

APCPHPを高速化してくれるモジュールなので、別になくてもEC-CUBEが動くといえば動く。

でもせっかくなので、APCモジュールをインストールしてみた。

yum install php-pecl-apc

もしリポジトリを追加してたら下のコマンドでどうぞ。

yum --enablerepo=epel,remi,rpmforge install php-pecl-apc

追記:
symfonyに書き換えられた今回のEC-CUBEは非常に重い。だからAPCは入れた方がいいよ。入れても遅いんだけど。。