読者です 読者をやめる 読者になる 読者になる

ノラプログラマーの技術メモ

ネットで調べても出てこなかった情報を載せていきたい技術系ブログ。

phonegapアプリが「APKのバージョンコードは100より大きい必要があります」などとはじかれる

問題

phonegapで作ったandroidアプリをバージョンアップしようとしたら、google playで下記のエラーが出て更新できない。

アップロードできませんでした
APK のバージョン コードは 100 より大きい必要があります。

f:id:kawai_norimitsu:20140517141136p:plain

環境

windows8.1
phonegap3.4.0

解決法

phonegapのプロジェクトフォルダ内にあるwww/config.xmlを編集する。
具体的には「versionCode」がないので追加する。

<!-- config.xml reference: https://build.phonegap.com/docs/config-xml -->
<widget xmlns     = "http://www.w3.org/ns/widgets"
        xmlns:gap = "http://phonegap.com/ns/1.0"
        id        = "com.kawaidesu.hoge"
        version   = "2.0.0"
        versionCode = "200">

    <name>ほげアプリ</name>

もちろんバージョンコードは数値を大きくしておくこと。